Couldn’t find any package by glob ‘dotnet-sdk-6.0’

If you encounter errors when install dotnet-sdk on Linux using dpkg or apt-get you may need to purge your microsoft packages like so:

sudo dpkg --purge packages-microsoft-prod && sudo dpkg -i packages-microsoft-prod.deb
sudo apt-get update

Then you can install the dotnet sdk again like so:

sudo apt-get update; 
sudo apt-get install -y apt-transport-https && sudo apt-get update && sudo apt-get install -y dotnet-sdk-6.0